The Ops Community

Cover image for Troubleshooting "ImagePullBackOff" Errors
Patrick Londa for Blink Ops

Posted on • Updated on • Originally published at blinkops.com

Troubleshooting "ImagePullBackOff" Errors

Have you deployed a new Service to your Kubernetes cluster lately and run into an issue? This is one of the most common issues you could receive:

The ImagePullBackOff Error

After you deploy to add a new pod to your cluster, you may want to validate that everything worked. To do that, you can run this standard command:

kubectl get pods

If you see the Status say "Running", then you’re all set. If you see "ImagePullBackOff", then it’s time to troubleshoot.

What does “ImagePullBackOff” mean?

The "ImagePullBackOff" error is saying that a container was unable to start because Kubernetes couldn’t pull the container image. "BackOff" indicates that Kubernetes will keep attempting to pull the image at an increasingly delayed interval if it remains unsuccessful.

Without a runnable image, the container doesn’t have the runtime environment and executable software it needs. For more detail, you can read about kubelets, agents on each Node that facilitate the container manifest, ensuring that the containers described actually have everything they need to run successfully.

What causes an “ImagePullBackoff” error?

These are the main causes for receiving an "ImagePullBackOff error":

  • Image Name is missing or misspelled
  • Image Tag is missing or misspelled
  • You need additional authentication
  • You have hit a rate or download limit on the registry

Manual Troubleshooting Steps:

  1. Run a kubectl describe pod [name] command

    By running this command, you will receive details about your pods, including an Event log.

  2. Review the Message for the Failed event

Start with lines that have the Reason marked as “Failed” and review why they failed by looking at the accompanying Message.

If you see Error response from daemon: repository does not exist or may require ‘docker login:

You should double-check that you spelled both the repository name and image name correctly.

If they are both spelled correctly, then you have an issue with authentication.
You will then need to add a Secret to your YAML file and reference the matching Secret in the PodSpec.

If you see Error response from daemon: manifest for [image name]: [tag] not found:

This means you may have a typo in the tag you are using, or the tag doesn’t exist in the repository. Fix the typo or specify a valid tag to resolve this error.

If you're still having trouble:

If you still are receiving an "ImagePullBackOff" error after addressing these common issues, then you may have hit a registry rate limit. For example, Docker Hub has a limit of 100 container pulls every 6 hours from one IP address.

You can either wait for the cap to reset, or there are some other workarounds, like authenticating your account or setting up a private Docker registry.

Let me know how this worked for you!

Discussion (0)